Issue with nnmaction not running NNMi 10.00/0.1/0.2

Problem
Issue with nnmaction not running 

Name                   PID  State          Last Message(s)
 OVsPMD               12380  RUNNING        -
 nnmaction                -  NOT_RUNNING    Exit on signal 17 Exit(1)
 nnmtrapreceivermd    12382  RUNNING        Initialization complete. Trap Receiver is running.
 nmsdbmgr             12381  RUNNING        Database available.
 ovjboss              12438  RUNNING        Initialization complete.


Verification Steps

Verify contains of the following file;
<NnmDataDir>/log/nnm/public/incidentActions.0.0.log 

Look for the following conditions;

SEVERE: com.hp.ov.nms.events.action.log.ActionLogger createActionServer:
Failed to get port number from /var/opt/OV/tmp/actionServer.port due to java.io.FileNotFoundException.
/var/opt/OV/tmp/actionServer.port.lock (Permission denied) : java.io.FileNotFoundException:
/var/opt/OV/tmp/actionServer.port.lock (Permission denied)
 
OR
 
SEVERE: com.hp.ov.nms.events.action.log.ActionLogger createActionServer: Failed to get port number from /var/opt/OV/tmp/actionServer.port due to java.io.FileNotFoundException. Port lock file not found  : java.io.FileNotFoundException: Port lock file not found
        at com.hp.ov.nms.events.action.server.ActionServer.createActionServer(ActionServer.java:205)
        at com.hp.ov.nms.events.action.server.ActionServer.main(ActionServer.java:314)


Cause 

Potential cause of this issue is file permissions being changed due to additional HP software being installed on the NNMi system.

Solution

To correct the problem perform the following steps;
* ovstop
 
* cd <NnmDataDir> 

* Check the current file permissions on the tmp directory
ls -ald tmp
The output should look like the following;
drwxrwsrwx   4 root root 4096 Nov 25 13:07 tmp

 If they don't then execute the appropriate commands here:
chown root:root tmp
chmod 777 tmp
chmod g+s tmp 

* Remove the actionServer.port and actionServer.port.lock files:
rm -f actionServer*

 * ovstart -c

Have more questions? Submit a request

0 Comments

Article is closed for comments.