LRE Silent Install Fails at Windows Smart Screen Notification When Using Network Virtualization

Disclaimer: The information provided in this article is for general informational purposes only. The author and the publisher do not guarantee the accuracy, completeness, or reliability of the information. The techniques and suggestions mentioned may cause harm if not implemented correctly. The author and the publisher are not liable for any damages resulting from the use or misuse of the information. Use your own judgment and exercise caution when applying the suggestions in this article. Always consult official documentation and experts, and test changes in a controlled environment before applying them to production systems. By using this information, you agree to hold the author and the publisher harmless from any liability or claim.

 

Applies to:
LoadRunner Enterprise [LRE] (All Versions)

 

Issue:
Remote silent install of LRE Host fails. While performing the silent install of a LRE Host, the following “Windows SmartScreen” message appears:

 

A screenshot of a computer error

Description automatically generated 

This pop-up will stop the process flow and cause the silent install to fail.

 

Cause:
Depending on your security settings, Network Virtualization files can be blocked when downloaded outside of the network. This is done by Windows to protect computers from unverified files and will need to be unblocked to complete the installation.

Remote installations are not supported with UAC enabled on the system. To circumvent this, UAC (User Account Control) must be disabled.

Windows Smart Screen filter will create a popup if enabled during the silent install. This filter will need to be disabled if this issue is encountered.

 
Resolution Steps:
Unblock Executable File Security Properties:

  1. Right-click one of the NV installation executable files located in <NV installation path>\Additional Components\Network Virtualization and select Properties.
  2. If there is an Unblock check box in the General tab, select it and click OK.
  3. Verify that the Unblock check box is gone.
  4. Repeat for each executable file in the Network Virtualization folder.

Network Virtualization (NV) files are blocked to protect computers from untrusted files and display a message when downloaded from the internet or FTP site.

 
A screenshot of a computer error

Description automatically generated 

Please see the documentation for your version of LRE under “Manage remote installations“ for more details: https://admhelp.microfocus.com/lre/

Disable User Account Controls (UAC):
1. Open a DOS prompt and Type regedit.

2. Navigate the registry tree to the following path:
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system"

3. Disable UAC by changing the DWORD value EnableLUA from 1 to 0.

 

A screenshot of a computer

Description automatically generated

4. Reboot the machine to apply the registry change (can save restart until end of next section as another registry edit reboot will be required).

Disable Windows Smart Screen:

1. Open a DOS prompt and Type regedit.

2. Navigate the registry tree to the following path:
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer"

3. Disable Windows Smart Screen by changing the DWORD value SmartScreenEnabled from 1 to 0.

 

Please Note: After the silent install is complete, you can re-enable UAC and SmartScreen by changing the registry values back to their default value(s) of 1.

 

Note: Remote installations are not supported on hosts located behind a firewall.

 

We hope this article provided you with the assistance you needed. If you would like to find out more regarding the Services and Support Offerings we provide, please reach out to our Sales Team.

Have more questions? Submit a request

0 Comments

Article is closed for comments.