UFT One License Error - BackEndManager.CheckLicense

Disclaimer: The information provided in this article is for general informational purposes only. The author and the publisher do not guarantee the accuracy, completeness, or reliability of the information. The techniques and suggestions mentioned may cause harm if not implemented correctly. The author and the publisher are not liable for any damages resulting from the use or misuse of the information. Use your own judgment and exercise caution when applying the suggestions in this article. Always consult official documentation and experts, and test changes in a controlled environment before applying them to production systems. By using this information, you agree to hold the author and the publisher harmless from any liability or claim.

Applies to:
UFT One (All Versions)

Issue:

While using or launching UFT one you received "An unexpected error occurred" message:

Clicking on "Detail" provided the following additional information:

"System.InvalidOperationException: The calling thread cannot access this object because a different thread owns it. at HP.QTP.BackEndServices.BackEndManager.CheckLicense..."

The HP.UFT.log within %APPDATA%\Micro Focus\UFT\Logs\ provides additional details:

HP.UFT.License [ 1] ERROR Autopass.IsLicensed failed: Object reference not set to an instance of an object.
System.NullReferenceException: Object reference not set to an instance of an object.
at com.hp.autopassn.core.AutopassN.generateLockDetectedEvent(Lock argLock)
at com.hp.autopassn.core.AutopassN.getProductFeature(Lock argLock, Int32 argFeatureID, String argFeatureVersion)
at HP.UFT.License.Autopass.AutopassApi.GetProductFeature(Int32 featureId, String featureVersion)
at HP.UFT.License.Autopass.AutopassApi.IsLicensed(Int32 implicitFeatureId)

Cause:

The issue occurs when the following conditions are met:

  • UFT One is launched with "Display Add-in Manager on startup" disabled
  • The previously used license is no longer considered "available" within AutoPass License Server (APLS) or the APLS server is unavailable

Resolution Steps:

  1. Confirm the APLS Server is available
  2. Run the Functional Test License Wizard and acquire a valid license
  3. Reopen UFT One
  4. Enable "Display Add-in Manager on startup" from Tools>Options, close and reopen UFT One.

We hope this article provided you with the assistance you needed. If you would like to find out more regarding the Services and Support Offerings we provide, please reach out to our Sales Team.

Have more questions? Submit a request

0 Comments

Article is closed for comments.